Pages

Wednesday, July 11, 2012

ccnp route ospf Implementation


OSPF Routing Implementation

==========================
OSPF Configuration

R1:
router ospf 1
network 172.30.0.1 0.0.0.0 area 0
router-is 1.1.1.1
redistribute static subnets metric 200 metric-type 2  == to send static route
subnet is used since by default ospf will try to summarize
E1 == means incrementation in metric
If only one exit point is there, then basically we will use E2 where metric won't increment. The default is type E2


R2 :
show ip int br
router ospf 1
netowrk 172.30.0.2 0.0.0.0 area 0
router-id 2.2.2.2
reload or clear ip ospf process
clear ip ospf process
netowrk 172.30.10.2 area 10


R3:
router ospf 1
show ip int br
network 172.30.20.3 0.0.0.0 area 20
network 172.30.0.3 0.0.0.0 area 0


R4
router ospf 1
router-id 4.4.4.4
netowrk 10.0.0.0 255.255.255.255 area 0


R5
show ip int br
router ospf 1
router-d 5.5.5.5
network 10.10.0.0 0.0.255.255 area 10
network 172.30.10.5 0.0.0.0 area 0

Loopback int are always summarized as /32 subnets
but we can tweak that by
ip ospf network point-to-point
this will advertise a real subnet

There is no pre-emption means once you elect the DR and BDR, you can't change the same until u "clear the process".

Ensure R1 as DR?
R1
int f0/0
ip ospf priority 200
and change the priority of R2 and R3 int as 0
This is typically done on NBMA network
Then neighbors relation between r1 and r2 and r1 and r3 is full
the neighbor relation between R2 and R3 is 2 way

Implement summarization to make routing table efficient
=================================
In case of eigrp u can do summarization of any of the network/router which is the beauty of eigrp but in case of ospf summarization is only supported in ABR and ASBR

R2
router ospf 1
area 10 range 10.10.0.0 255.255.252.0

R1
show ip route

R3
router ospf 1
area 20 range 10.20.0.0. 255.255.252.0

Implement summarization at ASBR
===============================
ASBR == R1
router ospf 1
summary-address 172.16.0.0 255.255.252.0

R2
show ip route == now E2 shoud be seen in output

ospf cannot distinguish between the high-speed GB ethernet segments since the cost for all the GB ethernet segment above 100mbps is 1
solution is use auto-cost reference command. This will give the actual cost.

R1
router ospf 1
auto-cost reference-bandwidth 10000 (mbps)

This should be done in all the routers

Implementing OSPF over NBMA
===========================
OSPF network Types

1. Broadcast, multi-access networks
- eg: ethernet, token ring
- single operation mode
- DR/BDR election, 10 sec. hellos, dual multicast add

2. Point- to-point networks
-eg: ISDN BRI/PRI , T1
-single operation mode
-NO DR?BDR, 10sec, hellos, single multicast add

3. NBMA
- eg: FR, ATM
_ Five modes of operation


NBMA Topologies
===============
HUB and SPOKE (STAR)
Advantage :cost Disadvantage :redundancy
not good for sensitive traffic

PARTIAL MESH
key location. buy a redundant connection for key points

FULL MESH
full redundancy, used un IT industry, MPLS

OSPF over NBMA : Five Modes
===========================
1. NBMA - rfc standard
2. point to multipoint - rfc standard
3. point to point -- cisco propreity
4. broadcast - cisco prop
5. point ot multipoint, non broadcast - cisco prop


1. NON-broadcast mode or NBMA
=============================
- default mode for x.25, FR, ATM
- neighbors are statically configured
- must be one subnet
- acts like a LAN environment
- DR/BDR elected (must have full connectivity)

deny multicast and broadcast at the same time.so when u add broadcast at the end it creates a psuedo broadcast means router sends broadcast style packet down each dlci enabled for broadcast with broadcast key-point. Here we are not sending one message instead we are sending a directed broadcast.

This leads to some issues:
rule of DR/BDR is to have full connectivity with all routers. but here we can have only one DR ie hub router having full connectivity with other routers.
but if it is full mesh we can select DR/BDR.

2. POINT-TO-MULTIPOINT MODE
=====================
- fixes issues with NBMA networks
- requires single subnet
- no DR/BDR elected
- neighbours automatically form

treats the cloud as series of point-to-point links
-the psuedo broadcast is allowed to send the messages

3. POINT-TO-POINT
=======================
-uses separate sub-interfaces
-no DR/BDR elected
-requires different subnets
-neighbors automatically forms.

problem is ip address consumption

4. Broadcast mode:
Its a simple LAN environment

5.point to multipoint, non-broadcast
Same as point to multipoint except the 4th point ie here neighbours won't form automatically.

No comments:

Post a Comment