By default classful routing protocols like RIP, EIGRP will do auto-summary.
BB
router eigrp 90
network 172.30.0.0 0.0.255.255
send hellos on any 172.30.0.0
and advertise these networks
network 10.1.0.0 0.0.255.255
no auto-summary
sh ip int br
R2
router eigrp 90
network 10.1.2.2 0.0.0.0 or 10.1.2.0 0.0.0.255
network 10.2.24.2 0.0.0.0
network 10.1.25.2 0.0.0.0
no auto-summary
show ip route
show ip eigrp neighbors
H == handle on which order routes are learned
SRTT == source round trip timer
RTO == retransmit timeout
Q == how many packets are in queue ..continuous static value above 0 means link problem ,,might be bandwidth issue
Seq num == version of the eigrp database running
R3
router eigrp 90
network 10.1.2.3 0.0.0.0
network 10.1.34.2 0.0.0.0
no auto-summary
show ip eigrp neighbors
show ip route
show ip eigrp topology
lists all the routes---P ie Passive which is good
eigrp never says it has one successor and other FS
The route matching the FD is called the successor and the rest are FS routes
BB
router eigrp 90
do show run | i ip route
ip route 192.168.1.0 255.255.0 Null0
network 192.168.1.0
How to set default route and advertise?
-one way is by static and type network but it advertises every n/w
-other way is ip default-network
BB
ip default-network 192.168.1.0 ==default network should be classful
show ip route
S*====means candidate default
but you won't see gateway of last resort here
eigrp should not form a neighbor relationship with any interface which is not running eigrp.
when you configure a passive interface, it will stop sending hellos and not form any neighbor relationship with any interface
but it will still advertise the n/w
R2
router eigrp 90
passive-interface f0/1
BB
router eigrp 90
passive-interface default means everything will become passive==all loopback interface
now only turn on the interface which you want
no passive-interface
Summarization in eigrp
eigrp does it under interface
BB
int s0/0
ip summary-address eigrp 90 172.30.0.0 255.255.248.0
R2# show ip route
If I get specific routes from another router then metric and AD doesn't matter.
How to perform unequal load balancing
eigrp has by default variance of 1 which means even though it can do unequal load balancing but does load balance on equal cost
path.
var 2 ==two times bad route as current one
BB
router eigrp 90
variance 2
do load balance across links which are twice bad
Advanced Implementation of eigrp
challenges poses by NBMA
FR is 2nd generation technology in the packet switched world
foundation ===connection through shared cloud
In ethernet we have MAC address, in FR we have DLCI ie simply no's
DLCI is locally significant
Hub and sopke design ==very inexpensive but if hub goes down everything goes down
full mesh == mpls ==everything connects everything
partial mesh==hybrid topology--as a redundancy backup will be there
How eigrp handles NBMA:
NBMA: broadcast and multicast are denied which cause a problem since eigrp use multicat 224.0.0.10
so eigrp can use "pseudo-broadcasts" or manual neighbors
HQ
int s0/0.1 multipoint
ip address 172.16.124.1 255.255.255.248
frame-realy map ip 172.16.124.2 102 broadcast
.3 103 broadcast
this is called a pseudo-broadcat feature.
Since this is multi-point so every interface is in same subnet.
or
router eigrp 25
neighbor ---- == whenever you use this command this will disable multicast. so you need to do this for all the neighbors
another issue is split-horizon
if you configure FR on a physical interface split horizon is disabled.
if you configure FR on a sub-interface split-horizon is enabled.===work more like point to point
BB
router eigrp 90
network 172.30.0.0 0.0.255.255
send hellos on any 172.30.0.0
and advertise these networks
network 10.1.0.0 0.0.255.255
no auto-summary
sh ip int br
R2
router eigrp 90
network 10.1.2.2 0.0.0.0 or 10.1.2.0 0.0.0.255
network 10.2.24.2 0.0.0.0
network 10.1.25.2 0.0.0.0
no auto-summary
show ip route
show ip eigrp neighbors
H == handle on which order routes are learned
SRTT == source round trip timer
RTO == retransmit timeout
Q == how many packets are in queue ..continuous static value above 0 means link problem ,,might be bandwidth issue
Seq num == version of the eigrp database running
R3
router eigrp 90
network 10.1.2.3 0.0.0.0
network 10.1.34.2 0.0.0.0
no auto-summary
show ip eigrp neighbors
show ip route
show ip eigrp topology
lists all the routes---P ie Passive which is good
eigrp never says it has one successor and other FS
The route matching the FD is called the successor and the rest are FS routes
BB
router eigrp 90
do show run | i ip route
ip route 192.168.1.0 255.255.0 Null0
network 192.168.1.0
How to set default route and advertise?
-one way is by static and type network but it advertises every n/w
-other way is ip default-network
BB
ip default-network 192.168.1.0 ==default network should be classful
show ip route
S*====means candidate default
but you won't see gateway of last resort here
eigrp should not form a neighbor relationship with any interface which is not running eigrp.
when you configure a passive interface, it will stop sending hellos and not form any neighbor relationship with any interface
but it will still advertise the n/w
R2
router eigrp 90
passive-interface f0/1
BB
router eigrp 90
passive-interface default means everything will become passive==all loopback interface
now only turn on the interface which you want
no passive-interface
Summarization in eigrp
eigrp does it under interface
BB
int s0/0
ip summary-address eigrp 90 172.30.0.0 255.255.248.0
R2# show ip route
If I get specific routes from another router then metric and AD doesn't matter.
How to perform unequal load balancing
eigrp has by default variance of 1 which means even though it can do unequal load balancing but does load balance on equal cost
path.
var 2 ==two times bad route as current one
BB
router eigrp 90
variance 2
do load balance across links which are twice bad
Advanced Implementation of eigrp
challenges poses by NBMA
FR is 2nd generation technology in the packet switched world
foundation ===connection through shared cloud
In ethernet we have MAC address, in FR we have DLCI ie simply no's
DLCI is locally significant
Hub and sopke design ==very inexpensive but if hub goes down everything goes down
full mesh == mpls ==everything connects everything
partial mesh==hybrid topology--as a redundancy backup will be there
How eigrp handles NBMA:
NBMA: broadcast and multicast are denied which cause a problem since eigrp use multicat 224.0.0.10
so eigrp can use "pseudo-broadcasts" or manual neighbors
HQ
int s0/0.1 multipoint
ip address 172.16.124.1 255.255.255.248
frame-realy map ip 172.16.124.2 102 broadcast
.3 103 broadcast
this is called a pseudo-broadcat feature.
Since this is multi-point so every interface is in same subnet.
or
router eigrp 25
neighbor ---- == whenever you use this command this will disable multicast. so you need to do this for all the neighbors
another issue is split-horizon
if you configure FR on a physical interface split horizon is disabled.
if you configure FR on a sub-interface split-horizon is enabled.===work more like point to point
No comments:
Post a Comment